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1 LED Snow: Simulation with ModelSim

1.1 Objectives

There is one tool you should still learn in firmware development: the simulator. Altera’s Quartus contains
a limited version of Mentor Graphics’ simulator, ModelSim. We cover an advanced example of random
number generation in hardware with the side-effect of illustrating the use of ModelSim. Covered in this
exercise:

• Synthesizable generation of random bits using the Linear Feedback Shift Register techinique;
• Synthesizable generation of gaussian random numbers - how to create and fill ROM structures;
• Illustration of fixed-point arithmetic in hardware;
• Functional simulation with ModelSim;
• Visualization of simulation waveforms, including real-valued waveforms, i.e., analog.
• Automated verification of designs via the VHDL assert facility.

1.2 LFSR Uniform Random Number Generation

A (Fibonacci) linear feedback shift register operates by shifting bits into the SR. The bits shifted in are
derived by tapping elements in the middle of the shift register and feeding them to XORs (Figure 1). By
properly choosing the taps, the LFSR can generate 0 and 1 bits with approximately equal probability and
with the maximal length of sequence 2m where m is the length of the register. By taking slices of the register,
pseudorandom uniform integers can be generated. We will use this as the starting block for random number
generation. The VHDL source listing is given in Section 3.2.

Figure 1: 8-bit linear feedback shift register with three taps.
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1.3 Box-Muller Generation of Normal Random Numbers

Given 2 uniform random variables in the interval (0, 1) u and v from the LFSR, they can be transformed
into normal variables via the equations

z1 =
√
−2 lnu cos 2πv (1)

z2 =
√
−2 lnu sin 2πv (2)

The variables z1 and z2 are normally distributed with mean 0 and unit standard deviation.

1.4 Fixed Point Representation

We have uniform random numbers from the LFSR and a method to transform them into normally distributed
numbers. Real number math is needed however. Without resorting to floating point math IP cores, we
can represent numbers with limited precision using fixed point math. Bit vectors are simply interpreted
differently. For example, if I want to represent real numbers from 0 to 10 and I know that I just need
precsion to 0.01 then I can use unsigned 10-bit numbers and carry implicitly the scale factor of 1024. That
is to say that a 10-bit binary number A represents the number:

rA =
A

210

Indeed, I can represent numbers up to 10.23 with this method. For example, the number 9.44 would be
represented by the 10 binary bits 1110110000. One can show that addition and subtraction work trivially
just carrying along the implicit scale. Multiplication and division must be handled carefully propagating the
scale factor.
Examining the gaussian entity (section 3.3), you can see that it contains two 512-element look-up ROM
structures:

• One called sine (line 41) holding the values of the sin(2πv) part of the Box-Muller transform;
• One called ln (line 42) holding the values of the

√
−2 lnu part.

Thus, computing the value of the two halves of the transform has been reduced to looking up values in
tables. As u and v are restricted by definition to the interval (0, 1) it is trivial to map these onto 512 address
values: the address i represents the real value

ui =
i+ 0.5

512

The values at each address location in the ROMs are 9-bit values. The odd choice of 9-bits was driven by the
Cyclone IV multiplier hardware - the DSP blocks contain 9×9 or 18×18 multipliers. The largest value that
the sines and cosines can take is ±1 so one could efficiently compress this range into a signed 9-bit integer
(range -256 to +255) by multiplying by 255 Multiplying by a power of two will make things much easier for
the hardware so we have to unfortunately throw away a bunch of dynamic range and use 128 as the largest
possible multiplier.
The square root logarithm table is a bit more complex: the largest value in that table occurs at address 0
where the number being represented is 0.5/512 = 0.000977.

√
−2 ln 0.000977 = 3.7233, thus the numbers

range this 9-bit table must span is (0, 3.7233). A scale factor of 64 works here.
To check that you are still following me I list a few values of the two ROMs used in the Box-Muller hardware
transformer (Table 1).

1.5 Pre-Lab Questions

Prior to coming to laboratory examine the lfsr.vhdl and gaussian.vhdl code listings given in Sec-
tion 3.
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i ui

√
−2 lnui LN ROM sin(2πui) SINE ROM

0 0.0010 3.7233 238 0.0061 0
1 0.0029 3.4155 218 0.0184 2
2 0.0049 3.2625 208 0.0307 3
3 0.0068 3.1577 202 0.0429 5
... ... ... ... ... ...
45 0.0889 2.2003 140 0.5298 67
... ... ... ... ... ...

509 0.9951 0.0989 6 -0.0307 508
510 0.9971 0.0766 4 -0.0184 509
511 0.9990 0.0442 2 -0.0061 511

Table 1: Some elements of the lookup ROMs used in the firmware normal random number generator. Column
1 is the address, 2 is the number in the interval (0, 1) that it represents. Column 3 is the real value of the
first part of the Box-Muller transform. Column 4 is the integer representation. Columns 5 and 6 are the
real and integer versions of the sine portion of Box-Muller.

1.5.1 Question A:

Fill in row 200 of the Table 1, above.

1.5.2 Question B:

What is the next state in the linear feedback shift register’s sequence if the current state is (MSB on the
left)

0010 1010 1110 0100 1101 0001 1100 0011?
Assume that the XOR taps are taken at 1, 5, 18, and 30 as they are in the led_snow driver.

1.5.3 Question C:

The n1 and n2 signals output by the gaussian entity are 18-bit values. Given the explanation of the fixed
point representations in section 1.4 above, how can you interpret the 18-bit numbers which the entity gives
as real-valued normal variates? To be explicit, how would you interpret the number 1110 0010 0111 1011
as a real number if it were produced by the entity? Note that this is a signed number so you must interpret
it with 2’s complement notation in mind.

1.6 Step-by-Step Instructions

Download the LED Snow Quartus project from:
https://www.physics.wisc.edu/undergrads/courses/fall2015/623/fpga-labs/led-snow-3.qar

and unpack it into a directory of your choosing. You should have 5 files containing the design:
lfsr.vhdl Linear feedback shift register design. It implements an m-bit register with 4 XOR taps, all

generic parameters;
gaussian.vhdl A combinational logic module which provides, on output, normal random variables given

two uniform random variables from the LFSR. It uses the Box-Muller method. This entity is synthesiz-
able and uses look-up tables to hold fixed-point representations of the two real-valued transformation
functions employed by Box-Muller.

rand_pack.vhdl A VHDL package which holds definitions for the other packages in this example. It demon-
strates how packages can be used to help organize code.
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Figure 2: Dialog box filled in to create a new simulation project

led-snow.vhdl Top-level FPGA driver for the random generators. It contains the LFSR and the gaussian
sub-modules and passes signals holding the uniform numbers from the shift register to the Box-Muller
transformation. It then drives the random output of either the LFSR or the gaussian module out onto
the LEDs to make a pleasing snow display (LFSR numbers) or a display based on normal random
numbers.

sim/gaussian_testbench.vhdl A simulation driver to test the functionality of the gaussian entity. The
simulator can be stepped and signals viewed in the wave window. Additionally, some VHDL features
for automatically checking the output of the limited precision fixed point Box-Muller transform against
a simulation-only implementation which uses 64-bit IEEE floating point numbers. Shows how one can
use numerical math functions in VHDL simulations.

Now setup the simulation project. This happens outside of Quartus using the Altera version of ModelSim.
Start the ModelSim application (e.g., search it from the Windows start menu). You will be prompted with
a dialog box that contains the button, Jumpstart. Click that and click “Create a Project” on the following
dialog. Name your simulation project and specify the project location as the sim subdirectory where you
unpacked your Quartus archive (see Figure 2). You will see another dialog inviting you to create or add
objects to the simulation project. The files are already there so click the “Add Existing File” icon and
locate and add all 5 files mentioned above into your simulation project. Note that the simulation driver file
gaussian_testbench.vhdl is in the sim subdirectory while the other 4 files are in the parent directory. You
will need to add the files in two steps, first the file gaussian_testbench.vhdl by itself and then the other
4 files can be added all at once. You should see a window with the project files as in Figure 3 when you are
ready to proceed to the next step. First, ensure that the rand_pack.vhdl file is compiled first. It contains
definitions needed by the other files. Click the “Compile → Compile Order ...” menu item and either click
the “AutoGenerate” button in the dialog that pops up or drag the rand_pack.vhdl file to the top of the
list. Now, click the “Compile → Compile All” button or menu item. The question marks should turn into
green checks if all is well.

Figure 3: ModelSim project files.
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Figure 4: Selecting the design unit simulation driver.

Click the “Simulate → Start Simulation ...” menu item. You will get a list of all design files that ModelSim
knows about (Figure 4). You must select a simulation top-level design unit. Your design files all go into the
work library. Expand the ‘+’ next to the library named work library and click gaussian_testbench, then click
the “OK” button to launch the simulation.
The simulation should now start but pause before simulating anything. You will probably need to tell it to
run for a longer amount of time - the default is 0.1 ns which is not long enough to observe the effects of
this simulation. First, add some waves to your wave window so that you can snoop on what the simulation
is doing. Drag all data objects from the Objects window (the slate blue one) to the wave window left gray
area. These are the signals in your top level simulation driver. You can also add the process variables
by activating the “Locals” window (menu item View →Locals should have a check mark next to it) and
then clicking the gaussian_testbench/ver process in the structure window, the white window labeled “sim
- Default” in the upper left of Figure 5). Select and drag all variables in the “Locals” windows below the
“–ver–” line to the wave window too.
Tell ModelSim you want 20µs of simulation time by entering “20 us” in the text box at the top where 100 ps
is written (box with “1 us” in Figure 5). Run the simulation by clicking “Simulate → Run → Run 100” or
typing F9. The simulator wave window will update but show you only the last few hundred ps of simulation
time. Expand the window to view the full simulation by selecting the wave window and typing ‘F’ or use
the zoom tools on the toolbar or use the “Wave → Zoom” submenu items.
ModelSim allows a pseudo-analog display of waveforms which is actually handy for this problem. Select the
n1 and n2 waveforms and right click the mouse. In the context pop-up menu which appears select “Format
→ Analog (custom) ...”. Set the waveform Height to 50 pixels, the Format to Analog interpolated, and the
Max and Min to ±25000. Your display should now appear as in Figure 7.

1.7 Things to Do

Switch back to “Literal” view for the waveforms by right clicking them and selecting “Format →Literal”.
Unless you are skilled at reading binary you may also want to right click and select “Radix →Decimal” to
display the waveforms n1, n2, b0, b1, nx, ny, and diff_x and diff_y as decimal numbers. Check that n1
and n2 are properly generated from the uniform integers b0 and b1 by computing the Box-Muller transform
yourself for 1-2 clock cycles. Do the values differ from the values you obtain? By how much? Is this expected?
The simulation driver code contains assert statements
The gaussian_testbench driver contains code to write out the signals to a text file which can be loaded into
a program like Excel for analysis. The file is located in the ModelSim project directory (probably the sim
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Figure 5: ModelSim workspace with elements illustrating how to access signal data objects as well as process
variables.

Figure 6: Basic waveform display.
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Figure 7: Modelsim analog waveform display.

directory under where you unpackaged the project archive) and it is called random-out.txt. Simulate some
tens of microseconds and then stop the simulator. Read the file into your favorite data analysis package. Do
the random variables follow their expected distributions?

1.8 Behavior on the DE0 Board

Compile the led_snow project and program the DE0. What do you see? Use the KEY0 button to switch
between the snow display and the gaussian jitter displays. What else can you do with a fast hardware source
of uniform and normally distributed random numbers? Can you think of good way to seed the random
numbers so that the same sequence doesn’t repeat itself? What about the question of repeating sequence?
Can you determine, using the hardware, the length of the LFSR random sequence? Is it 232?

2 Optional Exerises

Now that you have the basic tools for FPGA development, you are encouraged to sink your teeth into a
problem of your choice. Choose one of the problems below, or develop your own with the instructors.

2.1 Reading out the GSensor

An example entity which reads out the ADXL345 accelerometer and provides the X/Y acceleration values
as 12-bit quantities is included in the project archive at https://www.physics.wisc.edu/undergrads/
courses/fall2015/623/fpga-labs/GSExplore.qar Can you think of an interesting way to build on top of
this?
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3 Program Listings

3.1 VHDL Package

1 l i b r a r y i e e e ;
2 use i e e e . std_logic_1164 . a l l ;
3 use i e e e . math_real . a l l ;
4
5 package rand_pack i s
6
7 −− non−s y n t h e s i z a b l e generat ion of normal random v a r i a t e s
8 procedure box_muller ( r1 , r2 : i n r e a l ; z1 , z2 : out r e a l ) ;
9

10 −− s y n t h e s i z a b l e b lock f o r normal random v a r i a t e s
11 component gauss ian i s
12 port (
13 u , v : i n s td_log ic_vector (8 downto 0) ;
14 n1 , n2 : out s td_log ic_vector (17 downto 0)
15 ) ;
16 end component gauss ian ;
17
18 −− s y n t h e s i z a b l e uniform random from l i n e a r feedback s h i f t r e g i s t e r
19 component l f s r i s
20 gener ic (
21 M : in t eg e r := 32;
22 TAP1 : i n t e g e r := 1;
23 TAP2 : i n t e g e r := 2;
24 TAP3 : i n t e g e r := 17;
25 TAP4 : i n t e g e r := 29
26 ) ;
27 port (
28 c l k : i n s td_ log i c ;
29 u0 : i n s td_log ic_vector (M−1 downto 0) ;
30 pre : i n s td_ log i c ;
31 u : out s td_log ic_vector
32 ) ;
33 end component l f s r ;
34
35 end package rand_pack ;
36
37 package body rand_pack i s
38
39 procedure box_muller ( r1 , r2 : i n r e a l ; z1 , z2 : out r e a l ) i s
40 v a r i a b l e x : r e a l ;
41 begin
42 x := sq r t (−2.0 * log ( r1 ) ) ;
43 z1 := x * cos (2 .0 * MATH_PI * r2 ) ;
44 z2 := x * s i n (2 .0 * MATH_PI * r2 ) ;
45 end procedure box_muller ;
46
47 end package body rand_pack ;
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3.2 Linear Feedback Shift Register

1 l i b r a r y i e e e ;
2 use i e e e . std_logic_1164 . a l l ;
3
4 ent i t y l f s r i s
5 gener ic (
6 M : in t eg e r := 32;
7 TAP1 : i n t e g e r := 1;
8 TAP2 : i n t e g e r := 2;
9 TAP3 : i n t e g e r := 17;

10 TAP4 : i n t e g e r := 29
11 ) ;
12 port (
13 c l k : i n s td_ log i c ;
14 u0 : i n s td_log ic_vector (M−1 downto 0) ;
15 pre : i n s td_ log i c ;
16 u : out s td_log ic_vector
17 ) ;
18 end ent i t y l f s r ;
19
20 arch i tec tu re f i b ona c c i of l f s r i s
21 s i g n a l utmp : s td_log ic_vector (31 downto 0) ;
22 begin
23 u <= utmp ;
24
25 gen : process ( c l k )
26 begin
27 i f r i s ing_edge ( c l k ) then
28 i f pre = ’1 ’ then
29 utmp <= u0 ;
30 e l s e
31 utmp(30 downto 0) <= utmp(31 downto 1) ;
32 utmp(31) <= utmp(TAP1−1) xor utmp(TAP2−1) xor utmp(TAP3−1) xor utmp(TAP4−1);
33 end i f ;
34 end i f ;
35 end process ;
36
37 end arch i tec tu re f i b ona c c i ;
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3.3 Gaussian Random Number Generator

1 l i b r a r y i e e e ;
2 use i e e e . std_logic_1164 . a l l ;
3 use i e e e . numeric_std . a l l ;
4 use i e e e . math_real . a l l ;
5
6 ent i t y gauss ian i s
7 port (
8 u , v : i n s td_log ic_vector (8 downto 0) ;
9 n1 , n2 : out s td_log ic_vector (17 downto 0)

10 ) ;
11 end ent i t y gauss ian ;
12
13 arch i tec tu re rom of gauss ian i s
14 subtype word_t i s s igned (8 downto 0) ;
15 type mem_t i s ar ray (0 to 511) of word_t ;
16
17 funct ion in i t_logrom return mem_t i s
18 v a r i a b l e r , u : r e a l ;
19 v a r i a b l e tmp : mem_t := ( others => ( others => ’0 ’ ) ) ;
20 begin
21 f o r i i n 0 to 511 loop
22 u := ( r e a l ( i )+0.5) / 512 .0 ;
23 r := sq r t (−2.0* log (u ) ) ;
24 tmp( i ) := to_signed ( i n t e g e r ( r *64.0) , 9 ) ;
25 end loop ;
26 return tmp ;
27 end in i t_logrom ;
28
29 funct ion i n i t_s ine rom return mem_t i s
30 v a r i a b l e r , v : r e a l ;
31 v a r i a b l e tmp : mem_t := ( others => ( others => ’0 ’ ) ) ;
32 begin
33 f o r i i n 0 to 511 loop
34 v := ( r e a l ( i )+0.5) / 512 .0 ;
35 r := s i n (2 .0*MATH_PI*v ) ;
36 tmp( i ) := to_signed ( i n t e g e r ( r *128.0) , 9 ) ;
37 end loop ;
38 return tmp ;
39 end i n i t_s ine rom ;
40
41 s i g n a l s i n e : mem_t := in i t_s ine rom ;
42 s i g n a l l n : mem_t := in i t_logrom ;
43 s i g n a l x , y , z : word_t ;
44 begin
45 x <= ln ( to_integer ( unsigned (u ) ) ) ;
46 y <= s ine ( to_integer ( unsigned ( v ) ) ) ;
47 z <= s in e (( to_integer ( unsigned ( v))+128) mod 512) ;
48 n1 <= std_log ic_vector ( x*z ) ;
49 n2 <= std_log ic_vector ( x*y ) ;
50 end arch i tec tu re rom ;
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3.4 Simulation Driver

1 l i b r a r y i e e e ;
2 use i e e e . std_logic_1164 . a l l ;
3 use i e e e . numeric_std . a l l ;
4 use i e e e . math_real . a l l ;
5 use std . t e x t i o . a l l ;
6 use work . rand_pack . a l l ;
7
8 ent i t y gauss ian_testbench i s
9 end ent i t y gauss ian_testbench ;

10
11 arch i tec tu re s imu la t i on of gauss ian_testbench i s
12 s i g n a l c l k : s td_ log i c ;
13 constant pre load : s td_log ic_vector (31 downto 0) := x”FFFFFFFF” ;
14 s i g n a l load : s td_ log i c ;
15 s i g n a l rand : s td_log ic_vector (31 downto 0) ;
16 a l i a s b0 i s rand (8 downto 0) ;
17 a l i a s b1 i s rand (17 downto 9) ;
18 s i g n a l n1 , n2 : s td_log ic_vector (17 downto 0) ;
19 begin
20
21 urnd : l f s r gener ic map (M=>32, TAP1=>1, TAP2=>5, TAP3=>18, TAP4=>30)
22 port map ( c l k=>clk , pre=>load , u0=>preload , u=>rand ) ;
23
24 grnd : gauss ian port map (u=>b0 , v=>b1 , n1=>n1 , n2=>n2 ) ;
25
26 c lkgen : process
27 begin
28 c l k <= ’0 ’ ;
29 wait fo r 10 ns ;
30 c l k <= ’1 ’ ;
31 wait fo r 10 ns ;
32 end process c lkgen ;
33
34 st im : process
35 begin
36 load <= ’0 ’ , ’1 ’ a f t e r 25 ns , ’0 ’ a f t e r 50 ns ;
37 wait ;
38 end process st im ;
39
40 ver : process ( c l k )
41 v a r i a b l e a , b , x , y : r e a l ;
42 v a r i a b l e nx , ny : i n t e g e r ;
43 v a r i a b l e di f f_x , d i f f_y : na tu ra l ;
44
45 f i l e s a v e_ f i l e : t ex t open write_mode i s ”random−out . t x t ” ;
46 v a r i a b l e L : l i n e ;
47 begin
48 i f r i s ing_edge ( c l k ) then
49 a := ( r e a l ( to_integer ( unsigned (b0 )))+0.5)/512.0 ;
50 b := ( r e a l ( to_integer ( unsigned (b1 )))+0.5)/512.0 ;
51 box_muller (a , b , x , y ) ;
52 nx := in t eg e r (2.0**13 * x ) ;
53 ny := in t eg e r (2.0**13 * y ) ;
54 d i f f_x := abs ( nx − to_integer ( s igned (n1 ) ) ) ;
55 d i f f_y := abs ( ny − to_integer ( s igned (n2 ) ) ) ;
56 as se r t d i f f_x < 144 report ” l o s s ␣of ␣ p r e c i s i o n ␣ in ␣x : ␣” & natura l ’ image ( d i f f_x ) s e v e r i t y warning ;
57 as se r t d i f f_y < 144 report ” l o s s ␣of ␣ p r e c i s i o n ␣ in ␣y : ␣” & natura l ’ image ( d i f f_y ) s e v e r i t y warning ;
58 wr i t e (L , to_integer ( s igned (b0 ) ) ) ; wr i t e (L , s t r i ng ’ ( ” , ␣” ) ) ;
59 wr i t e (L , to_integer ( s igned (b1 ) ) ) ; wr i t e (L , s t r i ng ’ ( ” , ␣” ) ) ;
60 wr i t e (L , to_integer ( s igned (n1 ) ) ) ; wr i t e (L , s t r i ng ’ ( ” , ␣” ) ) ;
61 wr i t e (L , to_integer ( s igned (n2 ) ) ) ; wr i t e (L , s t r i ng ’ ( ” , ␣” ) ) ;
62 w r i t e l i n e ( save_f i l e , L ) ;
63 end i f ;
64 end process ver ;
65
66 end arch i tec tu re s imu la t i on ;
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3.5 LED Snow

1 l i b r a r y i e e e ;
2 use i e e e . std_logic_1164 . a l l ;
3 use i e e e . numeric_std . a l l ;
4 use work . rand_pack . a l l ;
5
6 ent i t y led_snow i s
7 port (
8 c l k : i n s td_ log i c ;
9 key : i n s td_log ic_vector (1 downto 0) ;

10 l ed : out s td_log ic_vector (7 downto 0)
11 ) ;
12 end ent i t y led_snow ;
13
14 arch i tec tu re behav i o r a l of led_snow i s
15 s i g n a l rand : s td_log ic_vector (31 downto 0) ;
16 s i g n a l load : s td_ log i c ;
17 s i g n a l ce : s td_ log i c ;
18 constant CLK_DIV : i n t e g e r := 2000000;
19 a l i a s b0 i s rand (8 downto 0) ; −− f o r r e a d a b i l i t y , d e f i n e a l i a s to
20 a l i a s b1 i s rand (17 downto 9) ; −− low bytes of the 32−b i t random
21 s i g n a l n1 , n2 : s td_log ic_vector (17 downto 0) ;
22
23 −− the func t i on below i l l u s t r a t e s the use of
24 −− s i g n a l a t t r i b u t e s to a l low unconst ra ined
25 −− ar ray type handl ing in func t i on s
26 funct ion th resh ( x : s td_log ic_vector ; l e v e l : r e a l ) return b i t i s
27 constant N : i n t eg e r := x ’ l ength ;
28 begin
29 i f unsigned ( x ) < to_unsigned ( i n t e g e r ( l e v e l * (2.0**N)) , N) then
30 return ’ 1 ’ ;
31 e l s e
32 return ’ 0 ’ ;
33 end i f ;
34 end funct ion th resh ;
35
36 begin
37 r0 : l f s r gener ic map (M=>32, TAP1=>1, TAP2=>5, TAP3=>18, TAP4=>30)
38 port map( c l k=>clk , pre=>load , u0=>(others=> ’1 ’ ) , u=>rand ) ;
39
40 g0 : gauss ian port map (u=>b0 , v=>b1 , n1=>n1 , n2=>n2 ) ;
41
42 −− hold the load l i n e high f o r 10 c lock s
43 −− 1 c lock would be f i n e − t h i s i s to
44 −− demonstrate r e s e t genera to r s
45 rst_gen : process ( c l k )
46 v a r i a b l e i n i t : i n t e g e r range 0 to 15 := 0;
47 begin
48 i f r i s ing_edge ( c l k ) then
49 i f i n i t < 10 then
50 load <= ’1 ’ ;
51 i n i t := i n i t + 1;
52 e l s e
53 load <= ’0 ’ ;
54 end i f ;
55 end i f ;
56 end process rst_gen ;
57
58 d iv : process ( c l k )
59 v a r i a b l e count : i n t e g e r range 0 to CLK_DIV−1 := 0;
60 begin
61 i f r i s ing_edge ( c l k ) then
62 i f count = CLK_DIV−1 then
63 count := 0;
64 ce <= ’1 ’ ;
65 e l s e
66 count := count + 1;
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67 ce <= ’0 ’ ;
68 end i f ;
69 end i f ;
70 end process d iv ;
71
72 d i s p l a y : process ( c l k )
73 v a r i a b l e i l e d : i n t e g e r range 0 to 7 ;
74 begin
75 i f r i s ing_edge ( c l k ) and ce = ’1 ’ then
76 i f key (0) = ’1 ’ then
77 −− use the 8 4−b i t nybbles of the 32−b i t
78 −− random r e g i s t e r to determine whether
79 −− the 8 LEDs should be turned on . I t
80 −− l ooks more l i k e snow i f the f r a c t i o n
81 −− of b i t s i s much l e s s than 50%.
82 f o r i i n 0 to 7 loop
83 l ed ( i ) <= to_X01( thresh ( rand (4* i+3 downto 4* i ) , 0 . 1 5 ) ) ;
84 end loop ;
85 e l s e
86 l ed (7 downto 0) <= ( others => ’0 ’ ) ;
87 i l e d := to_integer ( s igned (n1(15 downto 13))) + 4;
88 l ed ( i l e d ) <= ’1 ’ ;
89 end i f ;
90 end i f ;
91 end process d i s p l a y ;
92 end arch i tec tu re behav i o r a l ;
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